Podio experiencing latency issues
Incident Report for Podio
Resolved
This issue looks to be related to latency this morning, however unrelated to earlier incidents in March. We continue to investigate the cause behind the spike in performance and will post further updates as we learn more.
Posted 3 months ago. Mar 25, 2019 - 15:37 EDT
Monitoring
We are continuing to monitor, however Podio has been stable since 13:40 EST. Thanks for your patience. We will keep this incident open until we have confirmation the issue is resolved.
Posted 3 months ago. Mar 25, 2019 - 14:17 EDT
Identified
We have identified latency issues in Podio. The team is currently monitoring and working on the fix. We apologize for any inconvenience this issue might be causing.
Posted 3 months ago. Mar 25, 2019 - 13:56 EDT
This incident affected: Web and API.