Intermittent notification delivery

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 19:07 EDT

Update

This is likely to impact all email functionalities within Podio/Workflow Automation. We will provide updates here as soon as possible.
Posted Jul 10, 2025 - 15:54 EDT

Investigating

Some Podio customers may be experiencing issues with notifications. We are investigating this issue and we will provide updates here as soon as available.
Posted Jul 10, 2025 - 15:49 EDT
This incident affected: Email.