Delay to Podio Triggered Flows
Incident Report for Podio Status Page
Resolved
This incident has been resolved.
Posted Jul 10, 2023 - 17:23 EDT
Update
The application has recovered and we are now monitoring.
Posted Jul 10, 2023 - 17:16 EDT
Investigating
We are currently investigating increased latency
Posted Jul 10, 2023 - 16:51 EDT
This incident affected: Advanced Workflow Automation.