Podio web application facing performance delays
Incident Report for Podio Status Page
Resolved
Issue has been resolved.
Posted Oct 11, 2023 - 23:26 EDT
Monitoring
Fix has bee implemented , We are monitoring the systems.
Posted Oct 11, 2023 - 23:14 EDT
Investigating
Podio web application failing to load , We are currently investigating..
Posted Oct 11, 2023 - 23:06 EDT
This incident affected: Web.