Podio is down
Incident Report for Podio Status Page
Resolved
We have identified the root cause and will be implementing a solution shortly. In the meantime, we continue to monitor Podio for any operational impacts.
Posted Oct 26, 2023 - 15:06 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 26, 2023 - 13:46 EDT
Update
Podio is available and running however we still see some slowness and performance delays causing some operations to run slower than normal. We continue to investigate to ensure performance and speed get back to normal.
Posted Oct 26, 2023 - 13:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2023 - 12:33 EDT
Investigating
Podio is currently down. Our Operations team is looking to find the cause and fix the problem. We will update this space as soon as possible.
Posted Oct 26, 2023 - 12:29 EDT
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.