ShareFile authentication experiencing latency
Incident Report for Podio
Resolved
At this point, we have determined that the issue is fully resolved and the ShareFile application should be behaving normally as you login to Podio. Follow incident here: http://status.sharefile.com/incidents/0rr23r2svrcx

Should any further issues be seen, please contact Citrix Technical Support for assistance.
Posted 3 months ago. Sep 17, 2018 - 17:19 EDT
Investigating
ShareFile team is investigating an issue causing latency for the app. This issue will effect organizations using ShareFile authentication to access Podio. Follow incident here: http://status.sharefile.com/incidents/0rr23r2svrcx
Posted 3 months ago. Sep 17, 2018 - 14:16 EDT