Investigating errors on Podio
Incident Report for Podio
Resolved
All the services looks normal
Posted 7 months ago. Mar 11, 2019 - 16:02 EDT
Update
We are continuing to investigate this issue.
Posted 7 months ago. Mar 11, 2019 - 16:01 EDT
Investigating
We are investigating delays and performance issues at the moment, thanks for your patience
Posted 7 months ago. Mar 11, 2019 - 14:32 EDT
This incident affected: Web and API.