Delays for webhooks and GlobiFlow
Incident Report for Podio
Resolved
Queues are operational again and clear
Posted 6 days ago. Sep 13, 2018 - 16:05 EDT
Investigating
We are currently investigating the issue
Posted 6 days ago. Sep 13, 2018 - 15:44 EDT
This incident affected: Web and API.