We are receiving reports of Podio being unavailable for some users
Incident Report for Podio
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2018 - 21:39 EDT
Monitoring
Podio should be up and running, please let us know in Support if you still receive errors and we'll help investigate.
Posted 4 months ago. Jul 02, 2018 - 20:56 EDT
Investigating
We are currently investigating the issue
Posted 4 months ago. Jul 02, 2018 - 20:39 EDT
This incident affected: Web.