ShareFile Upload Download Issues - EU
Incident Report for Podio Status Page
Resolved
At this time, we believe we have made the appropriate adjustments to deem this issue as resolved. Citrix operations and engineering teams have taken action to mitigate the issue, and we are continuing to monitor to ensure service availability

Please contact Citrix Technical Support if there are any other issues utilizing the service.
Posted Jun 26, 2019 - 07:09 EDT
Investigating
We have been made aware of an issue, affecting a small subset of customers in our EU region who are experiencing issues uploading and downloading, when using the Citrix Files application and tools.

We are working to research and resolve the issue and will provide updates as soon as additional information is available
Posted Jun 26, 2019 - 05:48 EDT